20.04 - 如何安装共享库?

分享于 

3分钟阅读

ubuntu

  繁體

问题:

Cisco PacketTracer有问题

https://www.netacad.com/courses/packet-tracer


wolf@linux:/opt/pt/bin$ ./PacketTracer7 


./PacketTracer7: error while loading shared libraries: libQt5WebEngineWidgets.so.5: cannot open shared object file: No such file or directory


wolf@linux:/opt/pt/bin$ 



有些库不在


wolf@linux:/opt/pt/bin$ ldd PacketTracer7 | grep not


 libQt5WebEngineWidgets.so.5 => not found


 libQt5WebEngineCore.so.5 => not found


 libQt5Script.so.5 => not found


 libQt5ScriptTools.so.5 => not found


wolf@linux:/opt/pt/bin$ 



我尝试安装它,但不能工作


wolf@linux:/opt/pt/bin$ sudo apt install libQt5WebEngineWidgets.so.5 libQt5WebEngineCore.so.5 libQt5Script.so.5 libQt5ScriptTools.so.5


Reading package lists... Done


Building dependency tree 


Reading state information... Done


E: Unable to locate package libQt5WebEngineWidgets.so.5


E: Unable to locate package libQt5WebEngineCore.so.5


E: Unable to locate package libQt5Script.so.5


E: Unable to locate package libQt5ScriptTools.so.5


wolf@linux:/opt/pt/bin$ 



我还尝试将它更改为小写,并从名称中删除.so.5,但仍然不能工作。


sudo apt install libQt5WebEngineWidgets.so libQt5WebEngineCore.so libQt5Script.so libQt5ScriptTools.so



sudo apt install libQt5WebEngineWidgets libQt5WebEngineCore libQt5Script libQt5ScriptTools



sudo apt install libqt5webenginewidgets libqt5webenginecore libqt5script libqt5scripttools



正确方法是什么?


sudo apt install libqt5webenginewidgets5 libqt5webenginecore5



安装的库


wolf@linux:/opt/pt/bin$ ldd ./PacketTracer7 | g not


 libQt5Script.so.5 => not found


 libQt5ScriptTools.so.5 => not found


wolf@linux:/opt/pt/bin$ 




答案1:

试试这个:


sudo apt install libqt5webenginecore5 libqt5webenginewidgets5




答案2:

try


sudo apt install libqt5webenginewidgets5 libqt5webenginecore5 libqt5script5 libqt5scripttools5





SHA    分享  Shared  共享库  
相关文章