LibreOffice 7.0.1安装损坏

分享于 

5分钟阅读

ubuntu

  繁體

问题:

如何安装它?

我提取了LibreOffice安装程序ZIP文件,在DEBS文件夹中输入,然后使用以下命令执行所有包sudo dpkg -i *.deb

运行命令后遇到以下错误


dpkg-deb (subprocess): decompressing archive member: lzma error: compressed data is corrupt


dpkg-deb: error: <decompress> subprocess returned error exit status 2


dpkg: error processing archive libobasis7.0-core_7.0.1.2-2_amd64.deb (--install):


cannot copy extracted data for './opt/libreoffice7.0/program/libbiblo.so' to '/opt/libreoffice7.0/program/libbiblo.so.dpkg-new': unexpected end of file or stream




dpkg: error processing package libobasis7.0-base (--install):


dependency problems - leaving unconfigured


dpkg: dependency problems prevent configuration of libobasis7.0-calc:


libobasis7.0-calc depends on libobasis7.0-core (>= 7.0.1.2); however:


Package libobasis7.0-core is not installed.


libobasis7.0-calc depends on libobasis7.0-core (<= 7.0.1.2-2); however:


Package libobasis7.0-core is not installed.



最后它显示了


Errors were encountered while processing:


 libobasis7.0-core_7.0.1.2-2_amd64.deb


 libobasis7.0-base


 libobasis7.0-calc


 libobasis7.0-draw


 libobasis7.0-en-us


 libobasis7.0-extension-beanshell-script-provider


 libobasis7.0-extension-javascript-script-provider


 libobasis7.0-extension-mediawiki-publisher


 libobasis7.0-extension-nlpsolver


 libobasis7.0-extension-pdf-import


 libobasis7.0-extension-report-builder


 libobasis7.0-firebird


 libobasis7.0-gnome-integration


 libobasis7.0-graphicfilter


 libobasis7.0-images


 libobasis7.0-impress


 libobasis7.0-kde-integration


 libobasis7.0-libreofficekit-data


 libobasis7.0-math


 libobasis7.0-ogltrans


 libobasis7.0-onlineupdate


 libobasis7.0-ooolinguistic


 libobasis7.0-postgresql-sdbc


 libobasis7.0-python-script-provider


 libobasis7.0-pyuno


 libobasis7.0-writer


 libobasis7.0-xsltfilter


 libreoffice7.0


 libreoffice7.0-base


 libreoffice7.0-calc


 libreoffice7.0-dict-en


 libreoffice7.0-dict-es


 libreoffice7.0-dict-fr


 libreoffice7.0-draw


 libreoffice7.0-en-us


 libreoffice7.0-impress


 libreoffice7.0-math


 libreoffice7.0-writer


 libobasis7.0-librelogo



菜单项中可以看到LibreOffice条目,但无法启动它们

现在,当我试图卸载它们时,sudo apt-get purge libreoffice-core )我得到以下错误


The following packages have unmet dependencies:


 libobasis7.0-base : Depends: libobasis7.0-core (>= 7.0.1.2) but it is not installable


 Depends: libobasis7.0-core (<= 7.0.1.2-2) but it is not installable


 libobasis7.0-calc : Depends: libobasis7.0-core (>= 7.0.1.2) but it is not installable


 Depends: libobasis7.0-core (<= 7.0.1.2-2) but it is not installable


 libobasis7.0-draw : Depends: libobasis7.0-core (>= 7.0.1.2) but it is not installable


 Depends: libobasis7.0-core (<= 7.0.1.2-2) but it is not installable


 libobasis7.0-en-us : Depends: libobasis7.0-core (>= 7.0.1.2) but it is not installable


 Depends: libobasis7.0-core (<= 7.0.1.2-2) but it is not installable


 libobasis7.0-extension-beanshell-script-provider : Depends: libobasis7.0-core (>= 7.0.1.2) but it is not installable



怎么修复它?


答案1:

你选择了非常困难的方法,没必要。

"LibreOffice Packaging"团队提供了PPA,要安装LibO 7.0软件包,请使用:


sudo add-apt-repository ppa:libreoffice/libreoffice-7-0


sudo apt-get update


sudo apt-get install libreoffice


sudo apt-get dist-upgrade




答案2:

最好的方法是使用snap版本的LibreOffice。



bro  APT  Libre Office  
相关文章