20.04 - WSL 2不运行Ubuntu Error 0x80370102

分享于 

1分钟阅读

ubuntu

  繁體

问题:

今天,我决定从WSL 1升级到WSL2。在WSL 1上,让Kali或Ubuntu在WSL 1上运行都没有问题。在升级到WSL 2时,Kali和Ubuntu都未能升级到版本2。卸载并重新安装它们可以解决此问题。启动Kali或Ubuntu给出相同的错误:错误0x80370102 Screenshot


Installing, this may take a few minutes...


WslRegisterDistribution failed with error: 0x80370102


Error: 0x80370102 The virtual machine could not be started because a required feature is not installed.



以下是我系统的一些信息:

  • Windows 10 ver 10.0.190 41.388 (也称为SDK版本2004 )
  • Ryzen 3900x CPU
  • 32GB DDR4 RAM
  • Asus Tuf Gaming X570-Plus Motherboard w/ BIOS ver 1407

  • 答案1:

    在"添加/删除功能"中,必需启用Hyper-V功能。


    答案2:

    必须在BIOS中启用虚拟化,除此之外别无它法。



    Ubuntu