由于Python 3,HPLIP无法安装在20.04上(怎么办?)

分享于 

1分钟阅读

ubuntu

  繁體

问题:

我尝试安装最新的HPLIP,执行了下列操作:


sudo apt-get purge hplip hplip-data hplip-doc hplip-gui hpijs-ppds libsane-hpaio printer-driver-hpcups printer-driver-hpijs



sudo rm -rf /usr/share/hplip/



sudo apt-get autoremove



然后下载最新的HPLIP并通过本指南(ie sh hplip-3.20.2.run,并接受所有默认值)安装,我安装在ubuntu20.04上,我相信它使用的是python3,而不是python2.因此,HPLIP安装程序出现以下错误:

checking python2.7m... no ,error : cannot find python-devel support


答案1:

你可以安装python2


sudo apt install python2