dpkg - 安装内核版本5.5.0时出现问题

分享于 

2分钟阅读

ubuntu

  繁體

问题:

我使用Ubuntu 20.04,内核版本5.7.0。我想运行旧版本的内核(5.5.0 ),所以下载软件包:


cd /tmp/



wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.5/linux-headers-5.5.0-050500_5.5.0-050500.202001262030_all.deb



wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.5/linux-headers-5.5.0-050500-generic_5.5.0-050500.202001262030_amd64.deb



wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.5/linux-image-unsigned-5.5.0-050500-generic_5.5.0-050500.202001262030_amd64.deb



wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.5/linux-modules-5.5.0-050500-lowlatency_5.5.0-050500.202001262030_amd64.deb



sudo dpkg -i *.deb



不幸的是,我无法安装这个版本的内核,dpkg存在一些错误:


dpkg: error processing package linux-image-unsigned-5.5.0-050500-generic (--install):


 dependency problems - leaving unconfigured


Setting up linux-modules-5.5.0-050500-lowlatency (5.5.0-050500.202001262030) ...


Errors were encountered while processing:


 linux-image-unsigned-5.5.0-050500-generic




答案1:

你要使用lowlatency模块安装generic内核。

安装方法不对,你需要下载所有genericlowlatency软件包。


答案2:

是否只下载:


wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.5/linux-headers-5.5.0-050500_5.5.0-050500.202001262030_all.deb



wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.5/linux-headers-5.5.0-050500-generic_5.5.0-050500.202001262030_amd64.deb



wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.5/linux-image-unsigned-5.5.0-050500-generic_5.5.0-050500.202001262030_amd64.deb



然后


sudo dpkg -i *.deb





相关文章