在ubuntu 20.04上,无法安装mysql 5.7

分享于 

3分钟阅读

ubuntu

  繁體

问题:


sudo apt-cache policy mysql-server



它给我:


8.0.20-0ubuntu0.20.04.1 500


 500 http://pk.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages


 500 http://pk.archive.ubuntu.com/ubuntu focal-updates/main i386 Packages


 500 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages


 500 http://security.ubuntu.com/ubuntu focal-security/main i386 Packages


8.0.19-0ubuntu5 500


 500 http://pk.archive.ubuntu.com/ubuntu focal/main amd64 Packages


 500 http://pk.archive.ubuntu.com/ubuntu focal/main i386 Packages


5.7.31-1ubuntu18.04 500


 500 http://repo.mysql.com/apt/ubuntu bionic/mysql-5.7 amd64 Packages


5.7.30-0ubuntu0.18.04.1 500


 500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages


 500 http://security.ubuntu.com/ubuntu bionic-security/main i386 Packages



当我试图


sudo apt install -f mysql-client=5.7.30-1ubuntu18.04



给我一个错误


Version '5.7.30-1ubuntu18.04' for 'mysql-client' was not found.



当我运行时 sudo apt install -f mysql-client-5.7 命令,安装了mysql版本,但也找不到 mysql-community-server=5.7.30-1ubuntu18.04

我试图运行 sudo apt install -f mysql-community-server 它提供了以下错误:


mysql-community-server : Depends: mysql-client (= 5.7.31-1ubuntu18.04) but 8.0.20-0ubuntu0.20.04.1 is to be installed




答案1:

Mysql 5.7在Ubuntu 20.04不可用。使用mysql系统信息库时,Ubuntu 20.04仅可使用mysql 8.0和更高版本。

你需要从官方mysql站点下载mysql 5.7包及它依赖项,并通过在终端中执行下面的命令手动安装。


sudo dpkg -i <package name>




答案2:

后面的错误 mysql-community-server : Depends: mysql-client (= 5.7.31-1ubuntu18.04) but 8.0.20-0ubuntu0.20.04.1 is to be installed 是因为MySQL的多个版本可用,当你尝试安装MySQL community server5.7时,APT试图获取最新的MySQL客户端,它是8.0,因为所有客户端都有相同的优先级,这与MySQL 5.7不兼容。

要使APT fetch mysql-client 5.7,考虑更改优先级。


sudoedit /etc/apt/preferences.d/mysql



这可能有所帮助。


Package: mysql-server


Pin: version 5.7*


Pin-Priority: 1001



Package: mysql-client


Pin: version 5.7*


Pin-Priority: 1001



重试安装过程, sudo apt install mysql-server 现在应该默认获取5.7.



Ubuntu  APT  
相关文章