18.04 - 无法升级R

分享于 

2分钟阅读

ubuntu

 

问题:

系统 :ubuntu 18 . 04 . 4


Rscript --version


R scripting front-end version 3.4.4 (2018-03-15)



我的问题:升级R失败。

步骤:


sudo apt-get remove r-base r-base-dev


sudo add-apt-repository 'deb https://cloud.r-project.org/bin/linux/ubuntu bionic-cran35/'


sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E298A3A825C0D65DFD57CBB651716619E084DAB9 (as instructed here: https://cran.r-project.org/bin/linux/ubuntu/)


sudo apt update


sudo apt install r-base r-base-core r-recommended



输出:


The following packages have unmet dependencies.


 r-base-core : Depends: libreadline6 (>= 6.0) but it is not installable



尝试安装libreadline6时,我得到:


sudo apt install libreadline6


Reading package lists... Done


Building dependency tree 


Reading state information... Done


Package libreadline6 is not available, but is referred to by another package.


This may mean that the package is missing, has been obsoleted, or


is only available from another source



E: Package 'libreadline6' has no installation candidate




答案1:

您需要安装libreadline-dev,因为Bionic(18.04)中的libreadline6是一个虚拟软件包。



相关文章