更新过程中cryptsetup的问题

分享于 

1分钟阅读

ubuntu

  繁體

问题

我安装了一大堆更新,一个小时之后,我最终在终端窗口中得到了这个消息:


cryptsetup: WARNING: failed to detect canonical device of overlayfs


cryptsetup: WARNING: could not determine root device from /etc/fstab




答案1

如果不使用加密卷或交换分区,则不需要cryptsetup,只需卸载它,并使用以下命令重新启动:


sudo apt-get remove cryptsetup


# it's better to update and reinstall GRUB before rebooting


sudo update-grub


sudo grub-install /dev/<your_device_id>


sudo reboot





Crypt  
相关文章