升级 libc.so. 6: 未找到版本 `GLIBC_2.16'

分享于 

1分钟阅读

ubuntu

  繁體

问题

在python中导入库(cdms2)时,出现以下错误消息:


ImportError: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.16' not found (required by /usr/local/uvcdat/1.3.1/Externals/lib/libcurl.so.4)



如何强制apt更新到版本2.16?


答案1

有一个更安全的方法来运行一个应用程序,请勿在系统范围内更新该库。准备一组完整的更新库,把它们放到/catbed。然后运行


 /catbed/ld-linux.so.3 --library-path=/catbed:/whatever-else /usr/bin/python -python-args




版本  LIBC  
相关文章