安装软件时无法解析软件包依赖项

分享于 

5分钟阅读

ubuntu

  繁體

问题

安装media player软件包时出现问题。无法解析软件包依赖关系


This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.


 Depends: libc6 (>= 2.7) but 2.13-0ubuntu13 is to be installed


 Depends: libglib2.0-0 (>= 2.24.0) but 2.28.6-0ubuntu1 is to be installed


 Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.22) but 0.10.32-1ubuntu5 is to be installed


 Depends: libgstreamer0.10-0 (>= 0.10.26) but 0.10.32-3ubuntu3 is to be installed


 Depends: liborc-0.4-0 (>= 1:0.4.10) but 1:0.4.11-2 is to be installed


 Depends: libpostproc-extra-51 (>= 4:0.6-1~) but 4:0.6.4-1ubuntu1+medibuntu1 is to be installed


 Depends: libswscale-extra-0 (>= 4:0.6-1~) but 4:0.6.4-1ubuntu1+medibuntu1 is to be installed


gstreamer0.10-plugins-bad: Depends: libc6 (>= 2.7) but 2.13-0ubuntu13 is to be installed


 Depends: libcairo2 (>= 1.2.4) but 1.10.2-2ubuntu2 is to be installed


 Depends: libcdaudio1 (>= 0.99.12p2) but 0.99.12p2-9 is to be installed


 Depends: libdc1394-22 but it is not going to be installed


 Depends: libdirectfb-1.2-9 but it is not going to be installed


 Depends: libflite1 but it is not going to be installed


 Depends: libgcc1 (>= 1:4.1.1) but 1:4.5.2-8ubuntu4 is to be installed


 Depends: libglib2.0-0 (>= 2.26.0) but 2.28.6-0ubuntu1 is to be installed


 Depends: libgsm1 (>= 1.0.13) but it is not going to be installed


 Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.32) but 0.10.32-1ubuntu5 is to be installed


 Depends: libgstreamer0.10-0 (>= 0.10.32) but 0.10.32-3ubuntu3 is to be installed


 Depends: libjasper1 (>= 1.900.1) but 1.900.1-7ubuntu2 is to be installed


 Depends: libmodplug1 but it is not going to be installed


 Depends: libmpcdec6 (>= 1:0.1~r435) but it is not going to be installed


 Depends: libmusicbrainz4c2a (>= 2.1.5) but it is not going to be installed


 Depends: libofa0 (>= 0.9.3) but it is not going to be installed


 Depends: liborc-0.4-0 (>= 1:0.4.10) but 1:0.4.11-2 is to be installed


 Depends: libpng12-0 (>= 1.2.13-4) but 1.2.44-1ubuntu3 is to be installed


 Depends: librsvg2-2 (>= 2.26.0) but 2.32.1-0ubuntu3 is to be installed


 Depends: librtmp0 (>= 2.3) but 2.3-2 is to be installed


 Depends: libschroedinger-1.0-0 (>= 1.0.9) but it is not going to be installed


 Depends: libsndfile1 (>= 1.0.20) but 1.0.23-1build1 is to be installed


 Depends: libstdc++6 (>= 4.1.1) but 4.5.2-8ubuntu4 is to be installed


 Depends: libvpx0 (>= 0.9.0) but it is not going to be installed


gstreamer0.10-plugins-ugly: Depends: libc6 (>= 2.7) but 2.13-0ubuntu13 is to be installed


 Depends: libgcc1 (>= 1:4.1.1) but 1:4.5.2-8ubuntu4 is to be installed


 Depends: libglib2.0-0 (>= 2.24.0) but 2.28.6-0ubuntu1 is to be installed


 Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.26) but 0.10.32-1ubuntu5 is to be installed


 Depends: libgstreamer0.10-0 (>= 0.10.26) but 0.10.32-3ubuntu3 is to be installed


 Depends: libid3tag0 (>= 0.15.1b) but it is not going to be installed


 Depends: libmad0 (>= 0.15.1b-3) but it is not going to be installed


 Depends: liborc-0.4-0 (>= 1:0.4.10) but 1:0.4.11-2 is to be installed


 Depends: libstdc++6 (>= 4.1.1) but 4.5.2-8ubuntu4 is to be installed




答案1

转到ubuntu软件中心>>编辑>>软件源>>下载>>重新启动计算机后,选择美国。进入软件中心并键入wine并安装它


答案2

试试这个:

打开终端,并尝试以下命令:


sudo dpkg --configure -a 


sudo apt-get install -f



这就是我主要解决依赖问题的方法。


sudo apt-get update



获取最新的软件包索引,然后重复第一个命令。


答案3

转到软件源,并确保包含所有软件源

另外包括mediaubuntu存储库

然后


sudo apt-get update


sudo apt-get upgrade



如果问题仍然存在,可能是因为软件包列表损坏了,请尝试

sudo apt-get install -f