如何让Ubuntu识别我的nvidia显卡?

分享于 

3分钟阅读

ubuntu

  繁體

问题

如果我在终端中输入lspci| grep VGA,得到这个输出:


00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller(rev 09)


01:00.0 VGA compatible controller: NVIDIA Corporation Device 0fd1 (rev a1)



我使用此命令 dpkg --list | egrep '(nvidia|bumbl)' | grep ^ii


ii bumblebee 3.0-2~preciseppa1 nVidia Optimus support


ii bumblebee-nvidia 3.0-2~preciseppa1 nVidia Optimus support using the proprietary NVIDIA driver


ii nvidia-common 1:0.2.44 Find obsolete NVIDIA drivers


ii nvidia-current 295.40-0ubuntu1 NVIDIA binary Xorg driver, kernel module and VDPAU library


ii nvidia-settings 295.33-0ubuntu1 Tool of configuring the NVIDIA graphics driver



optirun glxspheres在kern.log中输出


NVRM: GPU at 0000:01:00.0 has fallen off the bus.


NVRM: GPU at 0000:01:00.0 has fallen off the bus.


NVRM: RmInitAdapter failed! (0x26:0xffffffff:1170)


NVRM: rm_init_adapter(0) failed




答案1

The driver won't work with few models

安装ubuntu后,执行以下操作

  • 在终端中键入以下内容:

    
    sudo add-apt-repository ppa:bumblebee/stable
    
    
    sudo apt-get update
    
    
    
    
  • 要使用专有的nvidia驱动程序安装Bumblebee:

    For 12.04 -13.04

    
    sudo apt-get install bumblebee bumblebee-nvidia virtualgl linux-headers-generic
    
    
    
    

    对于13.10:

    
    sudo apt-get install bumblebee bumblebee-nvidia primus linux-headers-generic
    
    
    
    
  • 重新启动重新启动。

  • 使用说明:

    要使用nvidia卡运行程序,请在终端中使用前缀optirun命令。

     
    optirun glxspheres
    
    
    
    

    Install mesa-utils


  • 答案2

    PS,不要将ironhide或xswat用于Optimus显卡


    答案3

    这需要安装新的NVidia驱动程序的beta版本(官方版本),但在安装它时必须使用许多命令行开关。


    答案4

    在ThinkPad T430的NVIDIA GPU型号NVS 5400M的Ubuntu 15.10上,我需要做的只是:

    
    sudo apt-get install nvidia-352
    
    
    
    

    其中,nvidia-352是找到的最新驱动程序:

    
    sudo apt-cache search nvidia-
    
    
    
    
    
    software-properties-gtk
    
    
    
    

    相关文章