当我尝试安装vscode时,snapd显示错误代码 400

分享于 

1分钟阅读

ubuntu

  繁體

问题

我刚刚尝试从软件中心安装vscode。

以下是发生的情况:

  • 我被要求注册Ubuntu One
  • 我被要求用土耳其语认证。这是预装了Ubuntu的新Entroware笔记本电脑。
  • 我输入了系统密码

我得到了这个:


Detailed errors from the package manager follow:


 snapd returned status code 400: Bad Request




答案1

你可以从命令行安装它,snap install vscode --classic


答案2

你可以从命令行添加存储库,然后从命令行安装Visual Studio Code,以下是命令:


curl https://packages.microsoft.com/keys/microsoft.asc | gpg --dearmor > microsoft.gpg


sudo mv microsoft.gpg /etc/apt/trusted.gpg.d/microsoft.gpg


sudo sh -c 'echo"deb [arch=amd64] https://packages.microsoft.com/repos/vscode stable main" > /etc/apt/sources.list.d/vscode.list'



然后运行以下命令完成安装:


sudo apt-get update


sudo apt-get install code # or code-insiders





cod  显示  SNA  snap  中间  错误代码  
相关文章