酷徒LOGO

14.04> 16.04失败;apt (> = 1.0.1 ubuntu2.13 ) 未安装


问题:

( 这里问题未解决。 由于时间限制,计算机被恢复到出厂设置。

我试图从 14.04升级到 16.04,但 apt 引发了这里错误:


The required dependency 'apt (>= 1.0.1ubuntu2.13)' is not installed.



这意味着什么我怎么修复它?

当我键入apt缓存策略的命令时


Shageenth@shageenth-Inspiron-3451:~$ apt-cache policy apt apt:


Installed: 1.0.1ubuntu2.11


Candidate: 1.0.1ubuntu2.11


Version table:


*** 1.0.1ubuntu2.11 0


100/var/lib/dpkg/status


1.0.1ubuntu2 0


500 http://us.archive.ubuntu.com/ubuntu/trusty/main amd64 


Packages



当我运行命令时发生错误:


sudo do-release-upgrade -d



它产生以下结果:


Checking for a new Ubuntu release


Get:1 Upgrade tool signature [198 B]


Get:2 Upgrade tool [1,265 kB]


Fetched 1,265 kB in 0s (0 B/s)


authenticate 'xenial.tar.gz' against 'xenial.tar.gz.gpg'


extracting 'xenial.tar.gz'



Reading cache



Checking package manager


Reading package lists... Done


Building dependency tree


Reading state information... Done


Building data structures... Done



Required depends is not installed



The required dependency 'apt (>= 1.0.1ubuntu2.13)' is not installed.




回答 1:

我今天遇到了同样的问题。 升级前请确认你的版本是最新版本的Ubuntu 14.04版。 ( 目前的Ubuntu 14.04.4 )

我的一个错误的镜子被粘在了 Ubuntu 14.04.3上。

所以先运行:


sudo apt update


sudo apt dist-upgrade



确保版本现在是 Ubuntu 14.04.4 ( 更新 2016年09月: 版的Ubuntu )。

cat/etc/lsb-release

并启动 Ubuntu 16.04安装


sudo do-release-upgrade -d




回答 2:

最好始终通过以下步骤更新:


sudo apt update


sudo apt dist-upgrade



如果上述操作失败,则可以手动执行以下步骤。 虽然这个问题已经过时,但是你可以改变版本号,因为链接仍然是相同的。

要从终端窗口升级你的apt 版本,请键入以下命令:


sudo apt-get download apt



如果上面没有工作,你还可以通过运行以下行来下载 wget:


wget http://security.ubuntu.com/ubuntu/pool/main/a/apt/apt_1.0.1ubuntu2.17_amd64.deb



然后键入


sudo dpkg -i apt*.deb



我在我的系统上尝试过这个。 以下是输出:


terrance@terrance-VirtualBox:~$ sudo apt-get download apt


[sudo] password for terrance: 


Get:1 http://us.archive.ubuntu.com/ubuntu/trusty-updates/main apt amd64 1.0.1ubuntu2.17 [954 kB]


Fetched 954 kB in 0s (1,127 kB/s)


terrance@terrance-VirtualBox:~$ ls


apt_1.0.1ubuntu2.17_amd64.deb Documents examples.desktop Pictures Templates


Desktop Downloads Music Public Videos


terrance@terrance-VirtualBox:~$ sudo dpkg -i apt*.deb


(Reading database.. . 168376 files and directories currently installed.)


Preparing to unpack apt_1.0.1ubuntu2.17_amd64.deb.. .


Unpacking apt (1.0.1ubuntu2.17) over (1.0.1ubuntu2.11).. .


Setting up apt (1.0.1ubuntu2.17).. .


Processing triggers for man-db (2.6.7.1-1ubuntu1).. .


Processing triggers for libc-bin (2.19-0ubuntu6.7).. .



如果在所描述的步骤之后,由于缺失的ccr依赖项,你可以完成。


wget http://security.ubuntu.com/ubuntu/pool/main/d/dpkg/dpkg_1.18.24ubuntu1_amd64.deb


sudo dpkg -i dpkg_1.18.24ubuntu1_amd64.deb



所有可以用于Ubuntu的软件包都可以在这里找到:

http://security.ubuntu.com/ubuntu/pool/main/


回答 3:

简单的修复。这已经为我工作。

在搜索框中打开你的"apt"类型的,可以让你假设" 1.0.1 ubuntu1.13"正在点击它,然后点击上面的应用按钮。

升级后。

在运行你的软件包之前,请确保关闭了突触软件包管理器

最终命令


sudo do-release-upgrade 



它应该能正常工作。






Copyright © 2011 HelpLib All rights reserved.    知识分享协议 京ICP备17041772号-2  |  如果智培  |  酷兔英语  |  帮酷