酷徒LOGO

apt使用 64位系统安装Teamviewer,但我得到了一个依赖错误


问题:

我试图安装Teamviewer,但是我得到一个依赖错误,

我收到此错误:


Unpacking teamviewer (from teamviewer_linux_x64.deb) ...


dpkg: dependency problems prevent configuration of teamviewer:


 teamviewer depends on lib32asound2; however:


 Package lib32asound2 is not installed.


 teamviewer depends on lib32z1; however:


 Package lib32z1 is not installed.


 teamviewer depends on ia32-libs; however:


 Package ia32-libs is not installed.



dpkg: error processing teamviewer (--install):


 dependency problems - leaving unconfigured


Errors were encountered while processing:


 teamviewer



我试过


sudo apt-get -f install



得到


Package ia32-libs is not available, but is referred to by another package.


This may mean that the package is missing, has been obsoleted, or


is only available from another source


However the following packages replace it:


 lib32z1 lib32ncurses5 lib32bz2-1.0



Package lib32asound2 is not available, but is referred to by another package.


This may mean that the package is missing, has been obsoleted, or


is only available from another source



E: Package 'lib32asound2' has no installation candidate


E: Package 'ia32-libs' has no installation candidate



甚至连这个都做不到


sudo dpkg -i teamviewer_linux_x64.deb



如果我强制安装


sudo dpkg --force-depends -i teamviewer_linux_x64.deb



尽管出现"正在设置Temviewer",但它给了我这个:

Enter image description here

如何修复此问题?


答案1:

问题是teamviewer_linux_x64.deb是针对64-bit系统的软件包,它使用了一个过时的软件包,试图在Debian之前调用多体系结构,该打包方案已更改,现在Teamviewer为i386和amd64体系结构分发了不同版本,因为它们不再需要多体系结构。

只需下载适用于Debian Ubuntu的软件包,并使用你喜欢的方法安装它,应该足够了,这个包还安装了一个存储库,所以在升级系统时它也应该自动升级。


答案2:

只需要修改dpkg --force-all -i *.deb 安装该软件包,请注意,它无法解析的唯一依赖项是libpng12-0,因此,在强制安装后,它在接口中没有映像,但是仍可运行。


答案3:

您需要安装i386的所有依赖项库(可能也适用于64位)。对于缺少的libpng12库,只需转到:https://packages.debian.org/jessie/i386/libpng12-0/download并安装


sudo dpkg -i ~/Downloads/libpng12-0_1.2.50-2+deb8u3_i386.deb



dep : libc6 ( > = 2.14 ), zlib1g ( > = 1:1.1.4 )


答案4:

TeamViewer 13.0 Linux的预览

TeamViewer 13.0后它不再基于wine,TeamViewer 13.0具有本机64-bit支持和Qt前端,.deb用于TeamViewer 13.0的Linux包,可以从官方TeamViewer网站

teamViewer 64-bit

teamViewer 32-bit





Copyright © 2011 HelpLib All rights reserved.    知识分享协议 京ICP备17041772号-2  |  如果智培  |  酷兔英语  |  帮酷