ce需要containerd.io > =1.4.1,但不能安装提供程序

分享于 

1分钟阅读

互联网

  繁體

问题:


$ sudo yum update


Updating Subscription Management repositories.


Last metadata expiration check: 2:40:27 ago on Wed 16 Dec 2020 07:53:10 AM CST.


Error: 


 Problem: package docker-ce-3:20.10.1-3.el7.x86_64 requires containerd.io >= 1.4.1, but none of the providers can be installed


 - cannot install the best update candidate for package docker-ce-3:19.03.14-3.el7.x86_64


 - package containerd.io-1.4.3-3.1.el7.x86_64 is filtered out by modular filtering


(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)




答案1:

您正在尝试在EL 8上安装为EL 7构建的软件包。这将无法正常工作,也不清楚您最初是如何做到的。更正Docker CE repo文件获取RHEL发行版的正确包版本,你应该使用它,而不是使用自定义的repo。