ubuntu更新出错,电脑没开机,我怎么修理它?

分享于 

6分钟阅读

电脑

  繁體 雙語

问题:

我让PC在重新启动后安装大量更新,我得到了一个控制台屏幕,说明了udevadm的一些错误。 Google告诉我,它是一个已知的Bug,因为系统在配置结束之前提示重新启动。 我尝试了解决方案,即从LiveCD引导,到正常安装和运行。


dpkg --configure -a 



我有很多错误,现在尝试将结果引导到不同的错误消息中:

内核崩溃- 不同步: 找不到 init。请尝试将init=选项传递给内核。

-。-。-

更新:使用android的Darth建议,我可以在没有错误消息的情况下运行 dpkg --configure -a。 但是启动到 2.6.23.25 仍然产生内核不同步错误消息,启动到 2.6.32.24 (。第一个更新开始的内核) 仍然产生udevadm错误消息,并且只引导到 2.6.32.23 工作区。 我还没有尝试启动旧版本的内核版本。

-。-。-

关于如何修复电脑的建议? 现在,我从光盘引导时无法获得 Internet,所以我想选择不需要它的选项。

操作系统是 10.04 64位。 配置 Bug的详细信息如下: https://bugs.launchpad.net/ubuntu/+source/devmapper/+bug/358654/comments/0

dpkg的错误消息是:

root@ubuntu:/# dpkg --configure -a设置samba通用( 2: 3。4.7~dfsg-1ubuntu3。)。 sh: 无法创建/dev/null: 权限被拒绝: 无法创建/dev/null: 权限被拒绝,无法打开/dev/null: 权限拒绝 dpkg: 处理samba常见( --configure ): 子进程安装脚本返回错误退出状态 13设置 linux-headers-2.6.32-25-generic ( 2.6.32 -25.44 ) 设置。 检查/etc/kernel/header_postinst.d. 运行部件:执行/etc/kernel/header_postinst./dkms 2.6.32 -25 -generic/boot/vmlinuz-2.6. 32-25-generic/etc/kernel/header_postinst. d/dkms: 第 7行:/dev/null: 权限被拒绝运行部分: /etc/kernel/header_postinst. d/dkms退出返回代码 1在/var/lib/dpkg/info/linux-headers-2.6. 32-25-generic.postinst 行 110处处理/etc/kernel/header_postinst.d 失败。 dpkg: 处理 linux-headers-2.6.32-25-generic ( --configure ) 出错: 已经安装的子进程安装脚本返回错误退出状态 2 dpkg: 依赖项问题阻止配置 smbclient: smbclient依赖于samba公共( = 2: 3。4.7~dfsg-1ubuntu3。) ;但是: 软件包samba公用还没有配置。 dpkg: 处理 smbclient ( --configure ) 出错: 依赖项问题- 离开未配置的设置 linux-headers-2.6.32-24-generic ( 2.6.32 -24.43 )。 检查/etc/kernel/header_postinst.d. 运行部件:执行/etc/kernel/header_postinst./dkms 2.6.32 -24 -generic/boot/vmlinuz-2.6. 32-24-generic/etc/kernel/header_postinst. d/dkms: 第 7行:/dev/null: 权限被拒绝运行部分: /etc/kernel/header_postinst. d/dkms退出返回代码 1在/var/lib/dpkg/info/linux-headers-2.6. 32-24-generic.postinst 行 110处处理/etc/kernel/header_postinst.d 失败。 dpkg: 处理 linux-headers-2.6.32-24-generic ( --configure ) 出错: 已经安装子进程安装脚本返回错误退出状态 2设置 gnome-terminal-data ( 2.30.2 -0 ubuntu1 )。 回溯( 最近一次通话): 文件"/usr/sbin/gconf-schemas", 行 107,在 fd = os.open("/dev/null",os.O_WRONLY) OSError中: [Errno 13 ] 权限被拒绝:'/dev/null'dpkg: 处理 gnome-terminal-data ( --configure ) 错误:子进程安装后安装脚本返回错误退出状态 1 dpkg: 依赖项问题阻止samba-common-bin配置: samba-common-bin依赖于samba通用(> = 2: 3。4.0~pre1-2 ) ;但是: 软件包samba公用还没有配置。 dpkg: 处理 samba-common-bin ( --configure ) 出错: 依赖问题- 离开未配置的dpkg: 依赖项问题阻止linux-headers-generic配置: linux-headers-generic依赖于 linux-headers-2.6.32-25-generic;: 软件包 linux-headers-2.6.32-25-generic 还没有配置。 dpkg: 处理 linux-headers-generic ( --configure ) 出错: 依赖问题- 离开未配置的dpkg: 依赖项问题阻止gnome终端配置: gnome终端依赖于 gnome-terminal-data (> = 2.30 ),但是: 软件包gnome-terminal-data还没有配置。 gnome终端依赖于 gnome-terminal-data ( <<2.31 ),但是: 软件包gnome-terminal-data还没有配置。 dpkg: 处理gnome终端( --configure ) 出错: 依赖项问题- 在处理时遇到未配置的错误: samba通用 linux-headers-2.6.32-25-generic smbclient linux-headers-2.6.32-24-generic gnome-terminal-data samba-common-bin linux-headers-generic gnome终端

对不起,无法格式化格式,从电话发布并修复这个键盘是不可以能的。


回答 1:

再次遵循该指南,但在 chroot 命令之后,请在运行 dpkg -a --configure 之前尝试以下操作:

mount -t proc proc/proc
mount -t devtmpfs none/dev

在运行 exit 之前,请记住 umount:

umount/proc
umount/dev


回答 2:

看起来你当前的内核只是部分安装了。 GRUB是否提供了使用旧内核的选择? 应该是,如果是的话,试试。



rep  BOO  引导  Ubuntu  REPA  Repair  
相关文章