postcss-flexbugs-fixes, PostCSS插件,试图修复flexbug的所有问题

分享于 

2分钟阅读

GitHub

  繁體 雙語
PostCSS plugin that tries to fix all of flexbug's issues
  • 源代码名称:postcss-flexbugs-fixes
  • 源代码网址:http://www.github.com/luisrudge/postcss-flexbugs-fixes
  • postcss-flexbugs-fixes源代码文档
  • postcss-flexbugs-fixes源代码下载
  • Git URL:
    git://www.github.com/luisrudge/postcss-flexbugs-fixes.git
    Git Clone代码到本地:
    git clone http://www.github.com/luisrudge/postcss-flexbugs-fixes
    Subversion代码到本地:
    $ svn co --depth empty http://www.github.com/luisrudge/postcss-flexbugs-fixes
    Checked out revision 1.
    $ cd repo
    $ svn up trunk
    
    PostCSS Flexbugs修复 Build Status

    这个项目试图修复所有问题的插件。

    Bug 4

    输入

    .foo { flex: 1; }.bar { flex: 11; }.foz { flex: 110; }.baz { flex: 110px; }

    输出

    .foo { flex: 110%; }.bar { flex: 110%; }.foz { flex: 110%; }.baz { flex: 110%; }

    Bug 6

    输入

    .foo { flex: 1; }

    输出

    .foo { flex: 110%; }

    这只修复了具有 flex 属性集的css类。 要修复包含 inside 容器的元素,请使用这里全局规则:

    * {
     flex-shrink: 1;
    }

    Bug 8.1. a

    输入

    .foo { flex: 10calc(1vw-1px); }

    输出

    .foo {
     flex-grow: 1;
     flex-shrink: 0;
     flex-basis: calc(1vw-1px);
    }

    用法

    postcss([require('postcss-flexbugs-fixes')]);

    有关环境的示例,请参阅 PostCSS 文档。


    plugin  pos  POST  FLEX  FIX  
    相关文章